Seznam změn

verze 1.4

verze1.4.10
dne2012-10-26
  • Export dat ve formátu XLS.

verze1.4.9
dne2011-01-08

verze1.4.8
dne2011-01-07
  • Upraveny sestavy Frekvence a Kontingence tak, aby je MS Excel lépe importoval pomocí svého HTML filtru.

verze1.4.7
dne2010-06-14
  • Opravena chyba z ver. 1.4.6, kdy nefungovalo filtrování dat.

verze1.4.6
dne2010-06-05
  • Opravena chyba, kdy nefungovala funkce pouze zaškrtnuté v dialogu filtru dat.
  • Pokud se zada u textoveho znaku prazdna podminka, budou vyfiltrovány znaky, u kterých nebyl vyplněn žádný text.

verze1.4.5
dne2010-01-07
  • Opravena chyba, kdy nešel zapnout filtr dat.

verze1.4.4
dne2009-12-11
  • Opravena chyba, kdy nešla vypnout inplicitní ordinalizace.

verze1.4.3
dne2009-09-15
  • Opravena chyba výpočtu ve frekvenčních statistikách vzniklá ve verzi 1.4.2.

verze1.4.2
dne2009-09-10
  • Ve frekvenčních statistikách se nezapočítávají skipped hodnoty do relativní četnosti validní sledovaného znaku.

verze1.4.1
dne2009-xx-xx
  • Opravena chyba při otvírání síťové databáze.

verze1.4.0
dne2009-01-25
  • Nová licenční politika.
  • Opravena chyba při výpočtu implicitní ordinalizace ve frekvencích.

verze 1.3

verze1.3.5
dne2009-xx-xx
  • Funguje default value v definici dotazníku při vyplňování odpovědí.
  • Nový interní prohlížeč html sestav.

verze1.3.4
dne2008-12-31
  • Formát pro přenos dat byl změněn z TXT na DAZ (komprimovaný původní TXT).
  • Import formátů CSV, DBF a EPI byl přesunut do nabídky Soubor→Otevřít data, protože se nejedná o import, ale o otevření souboru v jiném formátu.
  • Nástroje→Zobrazit všechna data zobrazí jen ty dotazníky, které souhlasí s aktuálním filtrem v editoru dat.
  • V tabulce Nástroje→Zobrazit všechna data lze zvolit, zda se u každého řádku bude zobrazovat jeho pořadí nebo číslo dotazníku a zadavatel dat.
  • Po otevření filtru dat se nastaví šířka sloupců automaticky podle šířky zobrazených dat.
  • Ve filtru dotazníků lze vybírat SKIPPED otázky..

verze1.3.3
dne2008-10-28

Byly opraveny tyto chyby:

  • Po importu CSV dat se neuloží dotazník, pokud nebyl upravován v editoru dotazníku.
  • Nově vložená otázka nešla pojmenovat (chyba v undo/redo frameworku).
  • Nešly vkládat číselné odpovědi s desetinnými místy.

verze1.3.3-rc2
dne2008-09-02
  • Přechod na QT ver. 4.4.1
  • Lze vymazat více označených otázek v editoru dotazníku.

Byly opraveny tyto chyby:

  • Opět pravena chyba v automatickém přeskakování vnořených podotázek.

verze1.3.3-rc1
dne2008-08-26
  • Funkce Undo/Redo v editoru dotazníků.
  • Registrační soubory mohou mít přípony *.reg nebo *.key.

Byly opraveny tyto chyby:

  • Opravena chyba v automatickém přeskakování vnořených podotázek.

verze1.3.2-rc1
dne2008-04-21
  • Opravena chyba ve statistikách počítaných z hodnot generovaných JavaScriptem.
  • Změněn formát automaticky generovaných exportních jmen na kratší formát Z[n][CamelCase]. [n] - číslo otázky, [CamelCase] znění - otázky bez mezer, první písmeno slova je vždy velké.

Byly opraveny tyto chyby:

  • V demoverzi lze statisticky zpracováva 100 dotazníků i při zaškrtnutí více otázek.

verze1.3.1
dne2008-02-15

Byly opraveny tyto chyby:

  • [59-3] Nefunguje export do CSV.

verze1.3.1-rc4
dne2008-02-14

Byly opraveny tyto chyby:

  • Mezní bod ordinalizace lze nastavit větší než 99.

verze1.3.1-rc3
dne2008-02-10

Byly opraveny tyto chyby:

  • Pokud byl do odpovědi na textovou otázku vložen znak | program mohl spadnout při výpočtech.

verze1.3.1-rc2
dne2008-01-11

Byly opraveny tyto chyby:

  • Pokud je kombinovaná otazka a někdo zadá prázdnou slovní část, program spadne při výpořtu statistik.
  • Zavřením editoru odpovědi pomocí Cancel se editovaná hodnota stejně uloží.
  • Lze vložit missing z editoru odpovědí i u otazek typu číslo
  • Pomocí hromadných úprav dat lze vkládat missing a skipped hodnoty
  • Přidány funkce setSkipped() a setMissing() do modulu Script.

verze1.3.0
dne2007-12-22
  • Nabídka „Nástroje/Zobrazit všechna data“ vygeneruje automaticky chybějící exportní jmena sloupců, které je dosud nemají.
  • Možnost nastavit ordinální hodnotu u znaků typu Check
  • Otázky ve výstupu frekvence jsou ve stejném pořadí, jako v dialogu pro jejich výběr.

verze1.3.0-rc2
dne2007-12-10
  • Upravena metoda vkládání hodnot znaků, které mají více než 9 zaškrtnutí.

verze1.3.0-rc1
dne2007-11-30
  • Opravena chyba 58.

verze 1.2

verze1.2.9
dne2007-11-09
  • Opravena chyba 57.
  • Javascript konzole

verze1.2.8
dne2007-10-15
  • Úvodní asistent dialog
  • Odstraněna chyba neaktivních ikon v editoru dotazníku pro neregistrované verze.
  • Import formatu TXT - možnost vybrat více souborů současně
  • V definici otázky lze zaškrtnout Kopírovat naposledy vloženou hodnotu, při zadávání nového dotazníku bude u takové otázky vždy předvyplněna tato hodnota.

verze1.2.7
dne2007-09-17
  • Pearsonův koeficient - oprava chyby ve výpočtu
  • Korelační koeficient - oprava chyby ve výpočtu

verze1.2.6
dne2007-09-15
  • Pearsonův koeficient
  • Korelační koeficient
  • Hromadné úpravy

verze1.2.4
dne2007-09-05
  • Dramaticky zpřesněn výpočet opěrných bodů.
  • Opravena chyba výpočtu normovaného Pearsnova koeficientu kontingence.

verze1.2.0
dne2007-08-20
  • Síťová verze.

verze 1.1

verze1.1.2
dne2007-07-05
  • Uživatelská příručka přidána do helpu.
 
sasd/seznam_zmen.txt · Poslední úprava: 2012/10/26 19:46 autor: fanda     Nahoru